Blackberry [Software] Phần mềm lập trình cho BB

Thảo luận trong 'Lập trình cho Di động' bắt đầu bởi Keeper, 16/4/09. Trả lời: 61, Xem: 42361.

  1. Keeper

    Keeper Thành viên

    Để tiện cho anh chị em developer, Keeper tổng hợp một số link nhanh của BlackBerry JDE và Simulator từ trang maxpda để download nhanh:

    BlackBerry JDE:

    BlackBerry JDE 4.1.0

    BlackBerry JDE 4.2.0

    BlackBerry JDE 4.2.1

    BlackBerry JDE 4.3.0

    BlackBerry JDE 4.5.0 Part 1
    BlackBerry JDE 4.5.0 Part 2

    BlackBerry JDE 4.6.1

    BlackBerry JDE 4.7.0 Part 1
    BlackBerry JDE 4.7.0 Part 2

    BlackBerry Simulator:

    BlackBerry Simulator 4.2.1.93 (8700 series)

    BlackBerry Simulator 4.2.2.114 (8300 series)

    BlackBerry Simulator 4.1.0.309

    BlackBerry 8100 Simulators OS 4.2.1.66 T-Mobile EU

    BlackBerry Email MDS 4.1.2.17

    Tiếp tục cập nhật...

    Cơ bản là JDE đi kèm với Simulator tương ứng. Tuy nhiên để tiện việc backward compatible và latest development thì Keeper khuyên các bạn dùng JDE mới nhất(hiện là 4.7) nhưng khi test thì chọn Simulator phù hợp.

    Nghĩa là nếu mình muốn phát triển 1 application nào đó cho dòng OS 4.5 thì mình nên test trên Simulator 4.5. Nếu Simulator báo thiếu package tức là dòng OS này ko support API mà bạn sử dụng. Còn chạy tốt thì tiếp tục test backward dùng Simulator thấp hơn.

    Tuy nhiên tốt nhất là luôn tham khảo BlackBerry Java API, xem class package mình sử dụng được hỗ trợ từ JDE Version nào thì cũng có nghĩa là OS version đó cũng hỗ trợ và như vậy dòng máy sử dụng OS version đó cũng hỗ trợ.

    Như vậy phần mềm mình viết sẽ tương thích với dòng OS nào mình có thể control và implement cũng như set requirement.

    Đối với application sử dụng Internet thì bắt buộc phải cài thêm BlackBerry Email MDS Simulator (JDE thường có kèm theo) để Device Simulator có thể connect to the internet as long as your PC is connecting to the Internet.

    Chú ý đây là link từ maxpda và mediafire nên tốc độ cực nhanh, nếu thiếu cái bạn cần thì chịu khó chờ hoặc lên BlackBerry.com download nhé. Ai sưu tầm được link nhanh thì cứ post nhé.

    Have fun guys :)

    PS: Link mediafire là sưu tầm của bác bLaCkBeRry.SpAm và từ một số nguồn khác
     
    :
    dobinghs, cuong205a, myloveptpm120 người khác thích nội dung này.
  2. miinhtu

    miinhtu Thành viên

    tienan1706, blackbmt, huyngo1772 người khác thích nội dung này.
  3. pisa

    pisa Thành viên

    blackbmt, huyngo177Keeper thích nội dung này.
  4. bacdh

    bacdh Thành viên

    dòng 8800, 8820 thì dùng JDE và Simulator nào vậy bạn?
     
  5. Keeper

    Keeper Thành viên

    Tùy OS của bạn mà chọn JDE phù hợp.

    Nhìn chung 8800 và 8820 bạn dùng OS 4.5 và JDE 4.7 hoặc 5.0 đều OK.

    Chúc vui.
     
    blackbmt thích nội dung này.
  6. superstar_nth

    superstar_nth Thành viên

    Mình cài JDE 4.5 xong. Config để build và generate ra được file alx rồi. Nhưng mình muốn test trên simulator, có điều mình chạy cái link Device Simulator không được, nó xuất hiện màn hình DOS được 1 chút rồi tắt. Không có gì hết.

    Mình vào thư mục bin, chạy trực tiếp file DefaultSimulator.bat và fledgelauncher.exe để chọn simulator chạy, bấm go cũng bị tình trạng trên.

    Xin hỏi Keeper lý do tại sao bị như thế và cách khắc phục.

    update
    Mình down riêng cái simulator 4.5.0.102 trên trang chủ thì chạy được rồi. Như vậy là cái simulator đi kèm với JDE 4.5 bị lỗi chăng?
     
  7. Keeper

    Keeper Thành viên

    Ko phải bị lỗi mà nó ko tạo ra được file dump do ko có đủ quyền :)

    WIn 7 thì lưu ý vụ quyền user nhé bạn :)

    Cụ thể là set quyền cho bạn có thể tạo file trong thư mục JDE là ok.

    Thân.
     
    superstar_nth thích nội dung này.
  8. nguyenhdu

    nguyenhdu Thành viên

    cho em hỏi vào cái trang maxpda gì đó mà không thấy JDE ở đâu hết sao mà download ạh
     
    AtoxicKeeper thích nội dung này.
  9. Keeper

    Keeper Thành viên

    Kéo xuống dưới có 2 hàng ngắn ngắn 1 hàng có số 1 1 hàng có số 2 tức là link download.

    Ban muốn downlaod cái nào?
     
    blackbmtcrusoe thích nội dung này.
  10. vuktbvc

    vuktbvc Thành viên

    mình đang dùng 8820, và định dùng JDE 4.7 gold và Simulator BlackBerry Email MDS 4.1.2.17 thế đủ chưa. hay cần gì thêm, mong chỉ giúp
     
    AtoxicKeeper thích nội dung này.
  11. Keeper

    Keeper Thành viên

    Thêm Simulator 8820 nếu muốn chính xác hơn.

    Thanks.
     
  12. vuktbvc

    vuktbvc Thành viên

    cám ơn bản chỉ, có thể nói chính xác hơn bản nào kg bác hay bạn chỉ rỏ link thì tốt. cái này mình mới nhập môn. Mong chỉ giáo. thank..........
     
    Keeper thích nội dung này.
  13. Keeper

    Keeper Thành viên

    Dùng simulator 87xx hay 83xx cũng được. Chỉ qua khác cái hình thôi, OS 4.5 hay 4.2 mới có khác biệt. Bạn tìm xem cái nào OS 4.5 hay 4.2 thì download, tùy vào OS version mà có 1 số API phụ thuộc.

    Thân.
     
  14. conmoi

    conmoi Thành viên

    khangvt1992, annova83, tienan17062 người khác thích nội dung này.
  15. superstar_nth

    superstar_nth Thành viên

    Ai cần soft, simulators, JDE có thể liên hệ trực tiếp với mình, mình chép cho. Nhiều quá up lên ko nổi.

    List simulator mình đang có:
    BlackBerry_Simulators_4.6.0.92_9000-T-MobileEU.exe
    BlackBerry_Simulators_4.7.0.75_9500-Vodafone.exe
    BlackBerry_Simulators_4.3.0.124_8330.exe
    BlackBerry_Simulators_4.3.0.97_8130-Verizon.exe
    BlackBerry_Simulators_4.6.1.66_8900.exe
    BlackBerry_Simulators_4.6.0.174_8220-Rogers.exe
    BlackBerry_Simulators_4.5.0.55_8800.exe

    JDE đầy đủ, có plugin cho Ecllipse... nói chung là các soft cần thiết cho lập trình di động. :)
     
    Keeper thích nội dung này.
  16. miinhtu

    miinhtu Thành viên

    Bác ở đâu vậy ạ? Ở SG bữa nào cafe giao lưu cho em chép với, :d
     
  17. Bumper

    Bumper Thành viên

    Simulator của Storm đây
    Code:
    http://down.maxpda.com/blackberry/74415.html
    BlackBerry JDE cho Storm
    Code:
    http://down.maxpda.com/blackberry/74414.html
     
    Keeper thích nội dung này.
  18. newbienoob1

    newbienoob1 Thành viên

  19. khoi

    khoi Thành viên

    Mình không thể cài JDE được nó kiểm tra rồi buột kết nối internet java rồi ra bản không biết dơnload cái nào nữa, bạn nào có kinh nghiệm hướng dẩn giúp
    cảm ơn
     
  20. vuktbvc

    vuktbvc Thành viên

    bác bỏ những cái kết nối INternet đi, là cài tiếp tục OK thôi.:angry6wn: